Leisure battery overheat and burning smell Help -- on holiday with a 1 year old


slimsurf

New member
HI

Any help appreciated -- we are in a t4 westfalia california 1992

hooked up and fridge running with a camera battery charger with no camera battery in it in the 230 v socket otherwise no electrics running

Left the van and returned to 'burning/electric smell' felt the leisure batteries and one of them was vey very hot

obviously unhooked from hook up and switched off everything and disconnected batteries.

I have checked what I can see fuses are intact and the only thing that is wrong although i had never tested this so it may have been wrong for some time is the trip with for the 230 v circuit white test button does not work.

Any ideas on how to proceed we are on day 2 of a 2week french holiday and I have a one year old on board I am not keen to give smoke inhalation injury to

we do need to run the fridge though -- I'm not sure whether it was the hook up overcharging the battery ? whether having something plugged in (my camera battery charger0 was the problem or whether its the battery itself or lastly ? is something shorting and drawing power through when hooked up ?

I also dont know whether I can trust that leisure battery again but its the expensive german gel original.

Any help at all appreciated
 
S

SoltiC

Guest
Leisure battery overheat and burning smell Help on holiday with a 1 year old

What would I look for in the cannon app that would tell me if a cell was bad or if the battery has a low state of health? I know leafspy can do it.
 

Top