Westfalia.org Community - Powered by vBulletin

Page 5 of 5 FirstFirst ... 345
Results 41 to 44 of 44

Thread: Fuel pump and filter

  1. #41
    Join Date
    Feb 2011
    Posts
    3

    Default

    Ok, First off thanks for the help!!!

    The issue with the starter was the ground and the issue with the power to the fuel pump was a broke wire from the relay.

    NOW... I have replaced the fuel pump and it has power. I'm still not getting any fuel I ordered used injectors that were taken off of a working motor. Still nothing. Where do I go to check the power to the injectors?

  2. # ADS
    Adsense Circuit advertisement
    Join Date
    Always
    Posts
    Many
     
  3. #42
    Join Date
    Jul 2010
    Location
    Snohomish, WA
    Posts
    112

    Default

    I'm not sure where you found the broken wire but look for another at the same place. According to my book, the fuel pump and injectors both get power from terminal 87 of the fuel pump relay. If that is where you found the broken wire (and there is only one on there now) there should be a second wire that goes from the same terminal on the relay to the injectors and the aux. air regulator. The wire is white. Check to see if there is voltage at the injectors. If there is power at the injectors then the supply side is good and we need to look at the control unit side. We need to make sure there is power at the injectors before going further. (pull the connector off and see if there is voltage on one terminal)

    You can also check that there is voltage at terminal #1 of the ignition coil. If there is, get someone to crank the engine while watching the voltmeter / test light to see if it flickers. If the light flickers then the hall generator in the distributor is working but if it does not then the hall generator needs to be diagnosed.

    Let me know what you find and we can move on.

  4. #43
    Join Date
    Feb 2011
    Posts
    3

    Default

    So I have replaced the injectors, fuel pump, and ecu. The motor will start with starting fluid so I know it has spark. I ran a live wire to the fuel pump so That is working but I dont get any fuel out of the injectors and 87 on the fuel pump relay is dead.

  5. #44
    Join Date
    Jul 2010
    Location
    Snohomish, WA
    Posts
    112

    Default

    If that's the case then we should focus on the relay. Here's what you should have:

    Fuel pump relay

    Terminal 85 - 12v from the ignition coil
    Terminal 86 - grounded by the ECM
    Terminal 30 - 12v from battery via a connection at the starter
    Terminal 87 - 12v to injectors and fuel pump when the ground is provided by the ECM

    Power supply relay

    Terminal 85 - 12v from the ignition coil
    Terminal 86 - ground at all times
    Terminal 30 - power from battery via a connection at the starter
    Terminal 87 - power to the ECM when terminal 85 has power from the ignition coil

    So, I would start by checking the power supply relay and fuel pump relay. You should have 12v at terminal 30 on both relays at all times. You should have ground at terminal 86 all of the time. Then, when the ignition switch is turned on there should be power at terminal 85. If you get power at terminal 85 then you should get 12v out of terminal 87. If you do not get 12v then you need to replace the relay.

    Once the power supply relay is sorted out then move onto the fuel pump relay. Terminal 85 should have 12v with the key on. When the engine cranks there should be a ground at terminal 86 which should close the relay and provide 12v out of terminal 87. If you have 12v at terminal 85 and 30, ground at terminal 85 but no 12v out of terminal 87 then you need to replace that relay.

    Power to the injectors comes off of the same relay that powers the fuel pump so if that is not closing then the injectors have no power. Bypassing and wiring stuff can help you diagnose but you need to make sure you find the root cause and correct that. Logic would dictate that you have one issue so if you don't find an issue then move onto the next thing to check. Do not make changes and then keep going as you might create more issues than you correct.

    Let me know.

Page 5 of 5 FirstFirst ... 345

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •