Westfalia.org Community - Powered by vBulletin

Results 1 to 4 of 4

Thread: Random Electrical Quirks on 2000 Eurovan

  1. #1
    Join Date
    Oct 2012
    Posts
    3

    Default Random Electrical Quirks on 2000 Eurovan

    So a few things are happening but I am not sure they are related:
    * AC compressor will almost violently kick on and off when it is hot outside
    * Controls for heat/AC blinks after starting for 10 seconds
    * solenoid that keeps you from shifting out of park just started failing
    * 50 amp main fuse blew while woking on solenoid and it also blew a couple months ago
    Any advise on where to start would be great, I'm just going to replace fuse and see what happens.

    Thanks, JJ

  2. # ADS
    Adsense Circuit advertisement
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Join Date
    Jul 2010
    Location
    Snohomish, WA
    Posts
    112

    Default

    Are you still having issues?

    It appears to me that the first two points you mention could be related. The 'blinking lights' for 10 seconds after start probably means there is an issue within the Climate system and that could be related to the compressor issue. You would need a shop that can access and 'read' the DTCs from the climate unit to find out what the control unit thinks the issue is.

    Second concern with the shift solenoid is concerning. You need to have a fairly large issue to blow a 50A fuse and that would be more than a solenoid issue. You said "....50 amp main fuse blew while woking on solenoid ..." so my advice would be to retrace your steps and try to figure out what you were touching when the fuse blew. I would think the wiring shorting to ground would be your issue so try to recreate the situation and see if there are any power wires near where you were working that could be shorting out. For the 50A fuse to blow I would expect to see some evidence of shorting (black marks, arcing on the sheet metal etc.) so a visual check should reveal some evidence.

  4. #3
    Join Date
    Oct 2012
    Posts
    3

    Default Thanks

    Thanks, so the mechanic found the short at the alternater but it is still acting weird occasionally with the lights dimming for a little while and now it is running rich. I appreciate the advice, I'll be trying to find a better local mechanic.

    Quote Originally Posted by scotsborn View Post
    Are you still having issues?

    It appears to me that the first two points you mention could be related. The 'blinking lights' for 10 seconds after start probably means there is an issue within the Climate system and that could be related to the compressor issue. You would need a shop that can access and 'read' the DTCs from the climate unit to find out what the control unit thinks the issue is.

    Second concern with the shift solenoid is concerning. You need to have a fairly large issue to blow a 50A fuse and that would be more than a solenoid issue. You said "....50 amp main fuse blew while woking on solenoid ..." so my advice would be to retrace your steps and try to figure out what you were touching when the fuse blew. I would think the wiring shorting to ground would be your issue so try to recreate the situation and see if there are any power wires near where you were working that could be shorting out. For the 50A fuse to blow I would expect to see some evidence of shorting (black marks, arcing on the sheet metal etc.) so a visual check should reveal some evidence.

  5. #4
    Join Date
    Jul 2010
    Location
    Snohomish, WA
    Posts
    112

    Default

    Good luck with your quest for a new guy. Depending on your location, there are probably people on here who may be able to recommend someone.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •