Westfalia.org Community - Powered by vBulletin

Results 1 to 3 of 3

Thread: 86 Westfalia won't turn off

  1. #1
    Join Date
    May 2012
    Posts
    3

    Default 86 Westfalia won't turn off

    I have an 86 Westfalia and when I turn it off, it keeps running. I tried replacing the ignition switch (x2) but still no love. The only way I can get it to turn off is by unplugging what I think is the ignition control unit. Little black box with two relays on the left hand side of the engine. That kills it but there is still juice running. The battery light is still on so I then disconnect the negative from the battery. Any suggestions on what the problem could be? I also tried swapping the two relays in the box to see if one was bad.

  2. # ADS
    Adsense Circuit advertisement
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Join Date
    May 2012
    Posts
    3

    Default

    update: I don't know much about cars, so maybe I was way off base, but I disconnected all the wires to the starter solenoid to see if the battery light would turn off if there was no power to that. It didn't

  4. #3
    Join Date
    May 2012
    Posts
    3

    Default

    nevermind, figured it out. Turns out there was some aftermarket switch added to the dash that keeps the power running. Not sure why but somehow it got flipped.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •